Playwright Prerequisite and System Requirements

Like any other automation, tool Playwright needs prerequisites and requirements before it can be run in an environment. 

System Requirements

The browser binaries work across three platforms Windows, macOS, and Linux.

  • Windows: Works perfectly fine with windows 10 or above or on the windows subsystem for Linux.
  • Mac OS: It needs 10.14 Mojave or above.
  • Linux: Depending on the version of Linux, additional dependencies are needed to run the browsers. Only Ubuntu 18.04 and 20.04 are officially supported.

Prerequisites

  1. Node JS: Playwright requires a node.js version that is 14 or above. It is recommended to download LTS version. To download and install Node follow below links:
  2. Visual Studio Code: This is the best IDE to work with Playwright. It is recommended to download LTS version. To Install Visual Studio select your OS:

Managed ad


Tarun Goswami
Tarun possesses over 12+ years of extensive expertise in software testing and automation utilizing diverse JavaScript and Java technologies. Concurrently, he has dedicated his free time to crafting insightful blogs within the field.